F-150 Raptor Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I feel like my 2018 Gen2 is cursed. My engine knocking was finally resolved thanks in GREAT part to the posts and responses from this site. Knowing what others can provide is a definite TOOL in the process to resolving maintenance issues.
The engine knocking was due to failed CAM phasers. The phasers have a plastic guide cover which fails. The fix is to replace the phasers with brass covered guides. This would have cost $2600 outside of warranty.

As of late several more items have occurred. And NO, I have not jumped or even taken my truck off road as of yet. Sad, I know but given the history here I'm wondering if it would hold together.
*A leaking piñon seal from the right front assembly,
*A cracked radiator,
*A leaking water pump,
*A failed sunroof shade cover motor

Now most recently:
*A leaking "something" causing water to drip down the cab facing side and interior (behind the head liner) of the passenger A post.

The water is getting under the carpet on the passenger side and on the cab side, drips into the a/c vent then glove box. I believe, not proven yet, this is due in LARGE part to the incompetent service by my dealer ship. While working on the sunroof shade cover, the technician misread the service report thus deciding to remove and reinstall the glass sunroof and motor.

Upon receiving the truck back the sunroof was not properly installed and a large wind gap became noticeable while driving down the highway. Returning the truck and having the shop supervisor do the repair, all seemed to be properly working. That was until todays rains when returning to the truck after shopping, my wife commented, "wow, where's all this water coming from". Great!! Back to the dealership on Monday.

If anyone knows an Anti-Voodoo chant, would you please say it on my behalf. I'm so tired of these issues with a new truck and only 47K miles. I'm so done with this!
 

·
Administrator
Joined
·
1,550 Posts
Maybe and exorcism would be better. Curious, did you buy it new or used? I have the GEN 1 and did the sunroof repair myself (cracked and broken plastic tracks). Maybe they changed it in the newer models, but the whole sunroof comes out as a unit (one reason it is so expensive to replace). I don't see how they could have replaced the motor without taking the whole thing out of the truck. To your point, there are rain/water tracks with the sunroof unit, most likely that is your water problem. They were not connected properly or something broke loose.
 

·
Registered
Joined
·
231 Posts
Anytime you guys want to jump on board and create a class action lawsuit I am game. Probably a lot of others too. I am going back for a third Timing chain Phaser repair on Monday. I have the original warranty in effect plus my extended warranty plus the last set of phasers are under their warranty. thank god or i would of already spent 6500 just repairing this three times. Its approaching the Lemon law.
 

·
Registered
Joined
·
231 Posts
I feel your pain. Been through the timimg chain multiple times. 4 wheel drive system prematurely engaging. The modules went out on the info screen. Transmission is jerky. Yes me too, this truck has been maticulasly maintained never jumped and only sees pavement as i am affraid that if i off road it bad or worse problems will arrise. Ford Performance?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
Maybe and exorcism would be better. Curious, did you buy it new or used? I have the GEN 1 and did the sunroof repair myself (cracked and broken plastic tracks). Maybe they changed it in the newer models, but the whole sunroof comes out as a unit (one reason it is so expensive to replace). I don't see how they could have replaced the motor without taking the whole thing out of the truck. To your point, there are rain/water tracks with the sunroof unit, most likely that is your water problem. They were not connected properly or something broke loose.
Exorcism indeed. I don't know how they went about changing out the motor for the sun roof. After bringing the truck back in they found the passenger side drain tube in the A pillar wasn't re-connected. Fun times.

To answer your question I bought the truck with 1100 miles on it. Wondering if the person before me knew better? Thanks for the reply.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
I feel your pain. Been through the timimg chain multiple times. 4 wheel drive system prematurely engaging. The modules went out on the info screen. Transmission is jerky. Yes me too, this truck has been maticulasly maintained never jumped and only sees pavement as i am affraid that if i off road it bad or worse problems will arrise. Ford Performance?
That's really interesting what your saying about the premature 4 wheel engagement. This has recently started on my truck in the last couple of months. It began as an intermittent sound from the left side while making Left turns from traffic lights. Sounds similar to an oversized wheel scrubbing against the wheel well. In the last week or so I'm noticing some type of engagement sound while under light load 40mph and slight acceleration. Both sides of the front sound like something is trying to engage.

Is this similar to your situation? I read in a post when I first joined someone was having something similar and said it was a clogged vacuum valve.

The problem with these things is duplication. The service advisor was straight forward and said Ford Corporate won't reimburse the dealerships if they don't have 1st hand verification of the issue. Really a bummer because this doesn't sound good if it's a "partial" engagement of the system. I'm getting the impression metal shavings are being created somewhere in the system as a result.
 

·
Registered
Joined
·
231 Posts
It is a shame. My truck runs like a champ again. Hopefully 3 times a charm. Here are my latest repair invoices. Seriously if any of you guys are getting strung along text me and I’ll be happy to speak to your service advisor. Show them these invoices.
 

·
Registered
Joined
·
231 Posts
The problem you guys are describing on the site pertaining to being intermittent only when warm does it on inclines and slight down hills. Noise is coming from the floorboard area. This also happened to me. Your problem my friend is your 4 wheel drive is prematurely trying to engage itself. That noise you hear is the actuator in the wheel hub. It’s so bad that you can feel it inside the truck. Ie floorboard. It’s a simple repair. Have the dealership open up the hood. On the drivers side above the wheel well in front of the windshield are one way pressure activated check valves. One of yours is leaking. Tell them to replace both!!!! Not only one. This happened to me to. Definitely the issue.
 

·
Registered
Joined
·
231 Posts
First you think it’s the turbos. Then you give it gas and let off. Nope. Not the turbos. Then you think the bouse is coming from the transmission so again you give it gas and let off. Nope not the transmission. It happens when only st speed approaching inclines or down hill. It’s hard to repeat it as the line /check valve will actually seal up again. I was most successful duplicating it for the service foreman by getting up to 75 on the freeway moving over to the fast lane where the wall is or K rail. That way the sound is more evident. Once he heard it he knew exactly what it was. 35,000 miles later no issues. Once repaired. Still good to go.
 
1 - 11 of 11 Posts
Top