Back Up Camera Issues

Discussion in '2013 Ford Raptor Forum' started by Trunkmnky, May 19, 2017.

  1. Trunkmnky

    Trunkmnky New Member

    Joined:
    Nov 6, 2013
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    San Diego
    Vehicle?:
    2013 Ford Raptor
    Color?:
    Tuxedo Black
    Engine:
    GEN1 6.2L
    I have a 2013 and my back up camera works about 50% of the time, the other time its a black screen that says talk to your dealership. Has anyone experienced this? Is my back up camera broken, could it it be a loose connection somewhere? thank you
     
  2. Big Bill

    Big Bill Active Member Moderator Site Supporter Level 5

    Joined:
    Aug 5, 2012
    Messages:
    2,220
    Media:
    36
    Albums:
    3
    Likes Received:
    288
    Trophy Points:
    83
    Location:
    USA
    Vehicle?:
    2013 Whipple Raptor700+HP
    Color?:
    Red
    Engine:
    GEN1 6.2L
  3. Trunkmnky

    Trunkmnky New Member

    Joined:
    Nov 6, 2013
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    San Diego
    Vehicle?:
    2013 Ford Raptor
    Color?:
    Tuxedo Black
    Engine:
    GEN1 6.2L
    Thanks I went to dealership and they just said I need a new camera but i have had bad experiences w the dealership replacing thing unnecessarily; its on maybe 70 percent of time so haven't changed it out yet. I think it has to be some connection issue bc if it's off I play with the wires under the tailgate and it sometimes comes back on
     

Share This Page