edelbrock super added

Discussion in 'Ford Raptor Performance Mods - 5.4 Triton V8' started by Airdog005, Dec 3, 2013.

  1. Airdog005

    Airdog005 New Member

    Joined:
    May 7, 2010
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Illinois
    Vehicle?:
    2010 5.4l raptor
    Color?:
    Molten Orange
    Engine:
    GEN1 5.4L
    Had Brenspeed in Indiana install Edelbrock supercharger in aug.
    Not to happy with tune did not dyno the truck after install do not know how much power I gained.
    Looking for a dyno shop in the chicago area to fine tune the motor.
    Have Stainless works complete header and exhaust ( if you do not want a drone do not beleive stainless works their mufflers suck), Will be working with Solo Performance in Canada for new exhaust.
    Power is awesome like a new turck. I go to Colorado twice a year, looking forward to seeing how it runs at 9,000 feet.
    I have the stock injectors,manifold,and K&N cai for sale.
    I will post pics Later.
     
  2. TeamJDMJ3

    TeamJDMJ3 JDM Engineering

    Joined:
    Nov 23, 2009
    Messages:
    472
    Likes Received:
    21
    Trophy Points:
    18
    Location:
    New Jersey
    Color?:
    Tuxedo Black
    Engine:
    GEN1 5.4L
    If your having issues with the tuning please contact us. We have installed and custom tuned more than a few of the 5.4L Raptors with an E Force. I bet our mail order tune will out perform and have better driveability, throttle response, and shifting then your current one! Call me at 732-780-0770

    JimIII
     
  3. mustangbesos

    mustangbesos Well-Known Member

    Joined:
    Jun 10, 2010
    Messages:
    7,775
    Likes Received:
    97
    Trophy Points:
    48
    Location:
    British Columbia
    Vehicle?:
    2010 Ford Raptor
    Color?:
    Tuxedo Black
    Engine:
    GEN1 6.2L
    Any updates on your raptor? Where's the damn pics :)
     
  4. hitmix300

    hitmix300 Member

    Joined:
    Nov 2, 2009
    Messages:
    403
    Media:
    5
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Michigan
    Vehicle?:
    2010 Supercharged
    Color?:
    Molten Orange
    Engine:
    GEN1 5.4L
    i've been busy too...

    [​IMG]
     
  5. mustangbesos

    mustangbesos Well-Known Member

    Joined:
    Jun 10, 2010
    Messages:
    7,775
    Likes Received:
    97
    Trophy Points:
    48
    Location:
    British Columbia
    Vehicle?:
    2010 Ford Raptor
    Color?:
    Tuxedo Black
    Engine:
    GEN1 6.2L
    Nice!! Have you had it out for a test run yet?
     
  6. TeamJDMJ3

    TeamJDMJ3 JDM Engineering

    Joined:
    Nov 23, 2009
    Messages:
    472
    Likes Received:
    21
    Trophy Points:
    18
    Location:
    New Jersey
    Color?:
    Tuxedo Black
    Engine:
    GEN1 5.4L

    Let me know if you need help with the tuning, my offer stands!:smileup:
     
  7. Lukenukem

    Lukenukem New Member

    Joined:
    Jan 2, 2017
    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    3
    Gender:
    Male
    Location:
    Macomb Twp, Mi
    Vehicle?:
    2010 Ford Raptor
    Color?:
    Molten Orange
    Engine:
    GEN1 5.4L
    Hi all, I just bought a 10/5.4 sup w/edlebrock and have some questions

    I think the tune is off.. the truck fall on its face when it shifts then returns into the power once its completed... is this normal?
     
  8. Big Bill

    Big Bill Active Member Moderator Site Supporter Level 5

    Joined:
    Aug 5, 2012
    Messages:
    2,158
    Media:
    36
    Albums:
    3
    Likes Received:
    279
    Trophy Points:
    83
    Location:
    USA
    Vehicle?:
    2013 Whipple Raptor700+HP
    Color?:
    Red
    Engine:
    GEN1 6.2L
    Get a hold of JDM (732) 780-0770 talk to
    Jim Jr.
     
  9. mustangbesos

    mustangbesos Well-Known Member

    Joined:
    Jun 10, 2010
    Messages:
    7,775
    Likes Received:
    97
    Trophy Points:
    48
    Location:
    British Columbia
    Vehicle?:
    2010 Ford Raptor
    Color?:
    Tuxedo Black
    Engine:
    GEN1 6.2L
    Any luck getting this resolved?
     

Share This Page