F-150 Raptor Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hello, first time thread starter here as I usually find everything I need by searching.
My truck was having some starting issues. I did the fuse relocation, and then a week later my fuel pump went out.
It’s a gem 1 raptoe 6.
I had it towed to my mechanic in the AM. He replaced the fuel pump and fuel pump control module. Calls me and said truck started right up. Come and get it.
I go to pick it up and as I’m paying for it, he says that there was a bunch of warning lights on the dash, he tried to clear them but they came right back up.

ABS light - check brakes, check engine and traction control off, check downhill assist.

I thought he was joking. I just left, got home and tried to disconnect battery, and removed my JET chip.
It cleared the check engine light and traction control light are off now. But abs/brake and downhill assist are still on.

I’m wondering if anyone has had this before. I got under the truck and looked for anything crushed or brokEn from the tow truck.
Repair shop is closed now and I’m gonna call back in the morning…
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
OK we found a fix. Fuel pump module had a problem with the wiring and blew a fuse, also the towing company strapped my truck wrong and crest the ABS sensor and brake sensor. Re-checked all the wiring on the fuel pump module, replace the ABS and brake sensor( tow truck paid) And now good to go
 

·
Moderator
Joined
·
2,658 Posts
Welcome to the forum. Wow it’s good to hear you got that all figured out. Now hopefully you can enjoy that bad boy.
 
1 - 6 of 6 Posts
Top