F-150 Raptor Forums banner

1 - 20 of 20 Posts

·
Registered
Joined
·
208 Posts
Discussion Starter #1
ive got just over 10.5K miles on my truck and noticed lately, occasionally when coming to a stop i get a brake squeal ? any one else have this issue? i called the dealership there are no TSB`s out, and was advised that the warranty on brakes is 1 year or 12,500 miles, up here in canada, anyone know what the usa warranty is on brakes?
ive been using the truck off road and wonder if its just some dirt between the pads ? will have to take it in for a look see i guess, will keep you posted.

cheers

ian
 

·
Registered
Joined
·
636 Posts
:shakehead: My Raptor, with ~10,600 miles, has developed a minor brake squeal as well.
-Noticeable when I backup or come to a slow stop

Please update your thread after you have them checked out. Thx!
 

·
Registered
Joined
·
22 Posts
brake squeak will only get worse boys! especially if its in mud a lot. I like it, makes me feel like im driving my race truck around town lol. the hippies dont like it very much
 

·
Registered
Joined
·
509 Posts
My brakes do the same. Started before I hit 3000 miles. Doesn't really bother me. I believe the brake warranty in US is 12,000 miles or 12 months.
 

·
Registered
Joined
·
209 Posts
Mine too

I'm blaming mine on sand, been doing it for about 2500 miles w/ light pedal pushing. I plan on taking the wheels off this week and cleaning it up. I've tried to blow the sand out after each time but some must of gotten in a spot.

current miles 8800
 

·
Registered
Joined
·
437 Posts
Mine do it when brakes are cold. Once they warm up it gets less noticeable but they still squeal the last few feet of the stop.5000 miles.
 

·
Registered
Joined
·
52 Posts
Exactly the same thing, just over 10k, always squeaked in reverse, from day one, today just noticed a squeak coming to a stop.
 

·
Registered
Joined
·
384 Posts
squeaking in reverse - 8k on mine. anyone have any solutions? seems like quite a few of us are suffering from the same issue.
 

·
Registered
Joined
·
111 Posts
I just turned 3,000 miles and mine started doing it a couple of days ago. I was thinking surface rust but IDK... I am in Germany... one of the wettest places on earth!
 

·
Registered
Joined
·
20 Posts
I have 10,000 and mine have been getting worse, only when cold though, as soon as they warm up alls good. It happens when comming to a stop slowly, anyone go for service yet? seems to be alot of squeaks here...
 

·
Registered
Joined
·
14 Posts
Mine started this around 5,000 miles. Fixed it this weekend by taking off the front calipers and applying grease to the contact points between the brake pads and the caliper. Be fairly liberal with the grease (esp around the top and bottom taps), but obvouisly avoid any areas which contact the rotor. My Explorer developed the same issue and was fixed the same way.
 

·
Registered
Joined
·
205 Posts
I just turned 3000 miles and we noticed the squeal during the last 20-30 feet of slow stops... We thought it was another car, but when heard it a couple more times, it was clear it was our Raptor. I still love the truck, but I am starting to become a little concerned with all of the quirks. I don't like making or accepting excuses from a $45K brand new vehicle.
 
1 - 20 of 20 Posts
Top