F-150 Raptor Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
I have a 2010 with transmission shifting problems. It shifts hard,acts like it's searching for the proper gear and when I start accelerating from a stop it feels like the brakes are dragging
 

·
Registered
Joined
·
277 Posts
I had the same problem and it ended up being the TCM .I had it replaced but but not soon enough an I lost the transmission . It was still under warranty and didn't cost anything. There is a bulletin on the issue.
 

·
Registered
Joined
·
9 Posts
Transmission failure

Hey my names max and I've been a member for a while but never really post on here.. hoping this is the correct thread, but anyways…

Today I was driving my 2011 6.2 sc raptor with 61,000 miles down a local highway in NJ when the transmission began to "slip". As i got on the throttle the engine would rev up high and barely accelerate (which it did for about a half mile) so i tried shifting into manual in effort to get off the highway. In M i shifted from 5th to 4th and felt a hard clunk/ shift, still no engagement, then tried to shift back to 5th and it wouldn't engage. Luckily i had enough speed to get over from the left lane and roll into a local public storage facility parking lot. Once off the highway i tried turning the car on and off but it would still not engage. An hour later when the tow truck came it was still the same. After talking to road side assistance ford sent a local tow company who picked up the truck and dropped it at the dealership later on. Im waiting for a call from ford on monday. Anyone ever hear of anything like this on the 6.2 raptors? Everyone I've talked to today has given me the "its a typical ford" The car has 61k on it and power train was up at 60K :( ……..

heres some background on my truck
Bought in 2011 and I'm the original owner. Last year I did the driveshaft recall and ford put the new one in fixing the "clunk". diff lock in the car isn't currenty working also and the rear diffs need to be serviced (visibly leaking) but i think think that would be totally unrelated.

After taking to my mechanic friends briefly they said its most likely a toasted flywheel, torque converted, or i just strait blew the transmission. I'd like to here what you guys think! Thanks.
-Max

mods:
-5 star sct 93 octane tune
-Volant throttle body spacer
-volant CAI
-roush catback w resonator delete
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #4 ·
I also have the 5 Star 93 Performance Tune and AFE CAI. Wonder if i try going back to the factory tune will it help. I'll let you all know if this works.
 

·
Registered
Joined
·
7,775 Posts
Damn, keep us posted on the outcome from FOrd!!
 

·
Registered
Joined
·
7,775 Posts
Yup, it will be in the thousands, I'm sure. Get them to seal the rearend at the same time, not a big deal, they all leak, had mine done while it was still under warranty. Hell, they might fix your rear end for free after they rape ya on the tranny!! :SHOCKED:
 

·
Registered
Joined
·
7,775 Posts
Just glad you didn't need a transmission, :str:
 

·
Registered
Joined
·
5 Posts
I have a 2010 with transmission shifting problems. It shifts hard,acts like it's searching for the proper gear and when I start accelerating from a stop it feels like the brakes are dragging
This is a long shot but did replacing the TCM fix the issue? My truck cuts out when you go to pass another vehicle and it acts like it can't find the proper gear.
 
1 - 14 of 14 Posts
Top